Minimig Discussion Forum

Discussing the Open Source FPGA Amiga Project
It is currently Mon Dec 18, 2017 4:23 pm

All times are UTC




Post new topic Reply to topic  [ 24 posts ]  Go to page Previous  1, 2, 3
Author Message
 Post subject: Re: Bug in TG68K
PostPosted: Mon Feb 18, 2013 5:30 pm 
Offline

Joined: Tue Nov 09, 2010 3:10 pm
Posts: 316
Dirk, gaula92: are you guys saying that even the leftmost red LEDs are not lit up? That is strange indeed, as the control CPU doesn't have anything to do with the caches, or the SDRAM, for that matter. Both files (.sof and .pof) work for me just fine, even if I recycle power to the board just before programming. I'll build a new version with the caches disabled (that is, only the new TG68K core and the minimig core changes made by boing4000).

Oh, the dropbox links I posted earlier (and the ones I send to you, Dirk, in a message) point to the newest build, as I've simply overwritten the files on Dropbox.

And just to be sure, can you tell me what kind of SDRAM memory chip is on your boards - is it Zentel or something else? Thanks.

EDIT: here is a build with disabled kickstart cache:
https://dl.dropbox.com/u/524989/minimig_de1_test1.sof
https://dl.dropbox.com/u/524989/minimig_de1_test1.pof

_________________
** my minimig builds: http://somuch.guru/ **


Top
 Profile  
 
 Post subject: Re: Bug in TG68K
PostPosted: Mon Feb 18, 2013 8:24 pm 
Offline

Joined: Sun Dec 28, 2008 3:00 pm
Posts: 59
@chaos
This core works for me.
The LED display shows F 04, the 04 changes to 06 and back to 04 every few seconds.

My DE1 Board has a PSC SDRAM no Zentel.


Last edited by Dirk on Tue Feb 19, 2013 4:15 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: Bug in TG68K
PostPosted: Mon Feb 18, 2013 10:24 pm 
Offline

Joined: Thu Jun 18, 2009 9:54 am
Posts: 349
I really thank you for your continued effort, Chaos!
I'm out in a small village in the mountains, so I won't be able to test the core until next friday because I haven't brought my DE1 with me.
My DE1 has ZENTEL ram chips: if I remember right, initial versions had stability problems depending on the ram chips brand. I thought it would be good to mention it.


Top
 Profile  
 
 Post subject: Re: Bug in TG68K
PostPosted: Fri Feb 22, 2013 3:12 pm 
Offline

Joined: Thu Jun 18, 2009 9:54 am
Posts: 349
I can confirm the last release, published by Chaos on Mon Feb 18, works great on my board, too!

I've found the first game that works on the Minimiv V1.1 but not on the fixed TG68K on DE1: Wizkid. It turns off the screen and there seems to be no response from the Minimig.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 24 posts ]  Go to page Previous  1, 2, 3

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Translated by Xaphos © 2007, 2008, 2009 phpBB.fr