Minimig Discussion Forum

Discussing the Open Source FPGA Amiga Project
It is currently Mon Oct 23, 2017 11:36 am

All times are UTC




Post new topic Reply to topic  [ 11 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: C-One Minimig GETS A HARD DRIVE!!!
PostPosted: Thu Jan 08, 2009 12:29 am 
Offline

Joined: Mon Dec 01, 2008 1:02 am
Posts: 109
From the C-One Yahoo Group...

Jens Said...

"Hi list,

and happy new year!

An internal core (not for release) now works with the primary IDE
port of the C-One. Tobias has made Minimig V1.23 as a proof of
concept, and the core requires small board modifications, which is
the reason why it's not meant for general release. A separate IDE
device is required for this - for example a CF-card with an IDE
adapter, a real harddrive or an IDE flash module. Such an IDE flash
module can be seen in the pictures section of the official website
http://www.c64upgra.de/c-one , where we have added three new pictures.

The modifications either require re-programming the 7064 CPLD (you'll
need a ByteBlaster for that), or soldering. Both is not desirable, so
our goal is to use hardfiles directly from the CF card that you
already have. This will work on all the boards out there without any
modifications, and it's also much more user-friendly, as you have the
full Amiga-installation in one place, or even multiple
Amiga-installations with different kickstarts and different hardfiles
on the same CF card.

The performance of 545k per second might look a little slow, but you
have to remember that we're on a plain un-accelerated 68000 processor
that shares memory with the chipset and another 68000 processor.
There's not much room for improvements, but we'll try.

ciao,
Jens"

All I have to say is this....

"AWESOME!!"

Rich


Top
 Profile  
 
 Post subject: Re: C-One Minimig GETS A HARD DRIVE!!!
PostPosted: Thu Jan 08, 2009 12:40 am 
Offline

Joined: Mon Dec 01, 2008 4:04 pm
Posts: 261
Location: Lake Charles, USA / Rio, Brazil
Excellent news! I just read this on Amiga.org and was coming here to post it, but you beat me to it. :D

I'll be happy to wait for the CF hard file support rather than attacking my board with a soldering iron. It's really turning into some serious competition between the Minimig development and the C-One. Personally I view the Minimig as the entry-level A500 clone while the much more expensive C-One is like the A2000 due to the added expansion options.


Top
 Profile  
 
 Post subject: Re: C-One Minimig GETS A HARD DRIVE!!!
PostPosted: Sat Apr 11, 2009 9:46 am 
Offline

Joined: Mon Feb 23, 2009 7:25 am
Posts: 134
Location: A large, overpopulated, underprotected,oversensitive place attached to scotland and wales.
Is there any kind of tutorial on how to get a hdd up and running on the c-one? I tried 3 different drives so far and it just doesn`t see them.


Top
 Profile  
 
 Post subject: Re: C-One Minimig GETS A HARD DRIVE!!!
PostPosted: Sun Apr 12, 2009 1:55 pm 
Offline

Joined: Mon Dec 01, 2008 1:02 am
Posts: 109
I would like to hear from someone that got this working also. I haven't tried yet myself.

(I haven't done any minimig anything lately... except the forums... just been busy I guess....)

I think I heard that the drive has to be formatted in Amiga format... I'm not sure if that would be the problem you are having though.

I thought I even heard that the drive had to be pre-formatted on a real amiga, but I'm not sure why you couldn't just format it right on the minimig..

Anyone?


Top
 Profile  
 
 Post subject: Re: C-One Minimig GETS A HARD DRIVE!!!
PostPosted: Mon Apr 20, 2009 11:15 am 
Offline

Joined: Mon Dec 01, 2008 4:04 pm
Posts: 261
Location: Lake Charles, USA / Rio, Brazil
Wish I could give you an answer as the Minimig side of my C-One is still dead and it need to be returned for investigation. I'm sure Jens will have it uo and running and back in my hands in no time.


Top
 Profile  
 
 Post subject: Re: C-One Minimig GETS A HARD DRIVE!!!
PostPosted: Tue Apr 21, 2009 12:23 pm 
Offline

Joined: Sun Apr 12, 2009 12:41 pm
Posts: 10
I'm not sure what sort of tutorial is needed but here's what I did. I got my extender board in yesterday, slapped in a standard Maxtor 4GB IDE drive to the master IDE bus like you would on any PC, 'booted' off of the WB 3.1 install disk on the Minimig, ran HD Tools, added a new drive, partitioned it into a 1GB System Partition, a 2GB 'Stuff' Partition (left 1GB free for whatever), saved the drive settings, rebooted, formatted partitions. In other words, I did it exactly how I would on a standard Amiga under WB 3.1. The only thing odd I noticed is that after you 'save' your configuration to the drive, it quits responding properly (it should tell you to reboot at this point). It didn't seem to affect anything. I took the install 'disk' out of DF0: and now it boots fine of the internal HD.


Top
 Profile  
 
 Post subject: Re: C-One Minimig GETS A HARD DRIVE!!!
PostPosted: Mon Apr 27, 2009 5:52 pm 
Offline

Joined: Mon Feb 23, 2009 7:25 am
Posts: 134
Location: A large, overpopulated, underprotected,oversensitive place attached to scotland and wales.
I did that too, But try to install anything other than WB onto it and it fails every time :(


Top
 Profile  
 
 Post subject: Re: C-One Minimig GETS A HARD DRIVE!!!
PostPosted: Thu May 07, 2009 12:19 am 
Offline

Joined: Sun Apr 12, 2009 12:41 pm
Posts: 10
turbonut2000 wrote:
I did that too, But try to install anything other than WB onto it and it fails every time :(


I don't know if you are on the c-one mailing list, but I'm having the same issue. It locks up anytime I try to move files over to it. Supposedly, it's a 'bug' but we'll see how it goes.


Top
 Profile  
 
 Post subject: Re: C-One Minimig GETS A HARD DRIVE!!!
PostPosted: Fri May 08, 2009 7:22 pm 
Offline

Joined: Mon Feb 23, 2009 7:25 am
Posts: 134
Location: A large, overpopulated, underprotected,oversensitive place attached to scotland and wales.
cone cores email group is v. quiet. Doesn`t seem to be a lot of progress on the hdd issue. or any of the other probs for that matter. I watched that project for months before deciding to buy one and within weeks of it being delivered everything kind of slowed to a crawl. Hope I didn`t waste my money :?


Top
 Profile  
 
 Post subject: Re: C-One Minimig GETS A HARD DRIVE!!!
PostPosted: Tue Jun 02, 2009 6:44 pm 
Offline

Joined: Tue Jun 02, 2009 6:33 pm
Posts: 1
Yep i ran into the same prob.
Wb works and thats it.
Tried to install something else and it stops responding.

does anybody know how to fix this ?????


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Translated by Xaphos © 2007, 2008, 2009 phpBB.fr