Minimig Discussion Forum

Discussing the Open Source FPGA Amiga Project
It is currently Tue Nov 21, 2017 12:15 pm

All times are UTC




Post new topic Reply to topic  [ 15 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: *** ERROR *** No Filesystem Found
PostPosted: Thu Dec 04, 2008 5:33 pm 
Offline

Joined: Mon Dec 01, 2008 1:02 am
Posts: 109
Ok, the FPGA extender arrived today and I installed it on my board. Everything seems to have gone smoothly!

I copied the Kickstart 1.3 ROM 512k (renamed KICK.ROM) into my minimig_pal and minimig_ntsc directories. Placed Workbench 1.3 ADF file (renamed df0.adf) into the same folders.

When I start the Minimig core I get an Amiga Text Screen that says...
----------------------------------------------
Minimig by Dennis van Weeren
Bug fixes, mods and extensions by Jakub Bednarski

Bootloader BYQ080718
FPGA core FAA000000

Agnus ID: $30 (NTSC) Denise ID: $FF

+------------------------+
*** ERROR ***
No filesystem found!



+------------------------+

--------------------------------------------

So far I have tried replacing my 32mb compact flash with a 2gb one, just to be sure it wasn't the error with not being able to read FAT12 formatted drives.
Honestly, I think 32mb would be formatted fat16 anyways.

Any idea what is missing? Do I have a bad file or something.

I replaced all of my files with the newboot201.zip from individual computers website onto and fresh formatted both of my CF cards.


Top
 Profile  
 
 Post subject: Re: *** ERROR *** No Filesystem Found
PostPosted: Thu Dec 04, 2008 6:01 pm 
Offline

Joined: Mon Dec 01, 2008 4:04 pm
Posts: 261
Location: Lake Charles, USA / Rio, Brazil
Hopefully mine will arrive today then. I'll let you know how I get on. Meanwhile, try emailing Jens and see if he has an "idiots guide" to what files need to go where. Once one of us cracks it we need to post something like:

Card:
<directory name>
file
file
file
<directory name>
file

etc.


Top
 Profile  
 
 Post subject: Re: *** ERROR *** No Filesystem Found
PostPosted: Thu Dec 04, 2008 9:45 pm 
Offline

Joined: Mon Dec 01, 2008 1:02 am
Posts: 109
I only had about 45 minutes to mess around, and then I had to go to a job.

My plans are to remove some of the files I put in and see what level it is failing at.

Unfortunately I need to go out tonight, but if I have a chance later I will try some troubleshooting of my own.


Top
 Profile  
 
 Post subject: Re: *** ERROR *** No Filesystem Found
PostPosted: Thu Dec 04, 2008 9:48 pm 
Offline

Joined: Tue Dec 02, 2008 12:57 pm
Posts: 26
Location: Italy
RchGrav wrote:

When I start the Minimig core I get an Amiga Text Screen that says...
----------------------------------------------
Minimig by Dennis van Weeren
Bug fixes, mods and extensions by Jakub Bednarski

Bootloader BYQ080718
FPGA core FAA000000

Agnus ID: $30 (NTSC) Denise ID: $FF

+------------------------+
*** ERROR ***
No filesystem found!



I can't see that message since I took out the SDram module.... :)
All seems to be working now, except PAL cores...

Ciao!

_________________
Amiga labels at: sites.google.com/site/retrolabels


Top
 Profile  
 
 Post subject: Re: *** ERROR *** No Filesystem Found
PostPosted: Fri Dec 05, 2008 12:47 am 
Offline

Joined: Mon Dec 01, 2008 4:04 pm
Posts: 261
Location: Lake Charles, USA / Rio, Brazil
So that's 2 of you working with NTSC and nobody with PAL. Hmmm...

Perhaps we need Jaqub's 60Hz PAL patch...


Top
 Profile  
 
 Post subject: Re: *** ERROR *** No Filesystem Found
PostPosted: Fri Dec 05, 2008 4:27 am 
Offline

Joined: Mon Dec 01, 2008 1:02 am
Posts: 109
Ok, so far I have tried both of my CF cards, I made a bunch of minimig_pal, minimig_pal1, minimig_ntsc, etc. dropping different kickstarts in each.

Still have the filesystem error message.

I have to assume its the size of my CF cards, one is 32MB, and the other is 2GB. I have tried FAT16 and FAT32 w/ a variety of cluster sizes, large, small and default. Going crazy!

I wonder if its my adf file, maybe I need to download that mickey.adf or something.

Pikkey... what size is your CF card?

I just chased down a 1GB sandisk... gonnna try that next.

Rich


Attachments:
IMG_0062.JPG
IMG_0062.JPG [ 38.47 KiB | Viewed 3672 times ]
Top
 Profile  
 
 Post subject: Re: *** ERROR *** No Filesystem Found
PostPosted: Fri Dec 05, 2008 7:20 am 
Offline

Joined: Tue Dec 02, 2008 12:57 pm
Posts: 26
Location: Italy
>>> so far I have tried both of my CF cards, I made a bunch of minimig_pal, minimig_pal1, minimig_ntsc, etc. dropping different kickstarts in each.
>>> Going crazy!

:) :) :) same here...I spent lot of night hours testing/mixing files :) But at the end I won a little battle (Pal still doesn't work)


>>>I wonder if its my adf file, maybe I need to download that mickey.adf or something.

no, if things are correct, you should see the gray(s) screen cycling, tipical when you power on any Amiga

>>> Pikkey... what size is your CF card?

I've succesful tested a 128mb and 2GB, both Fat32 formatted
I'm not sure yet, but seem that the most important source of troubles are the RAM modules..
I've mixed so much things that I'm not sure of nothing..... ;)
But now that I have a core working, I can start testing kickstart files and cores one by one..

_________________
Amiga labels at: sites.google.com/site/retrolabels


Top
 Profile  
 
 Post subject: Re: *** ERROR *** No Filesystem Found
PostPosted: Fri Dec 05, 2008 3:31 pm 
Offline

Joined: Mon Dec 01, 2008 4:04 pm
Posts: 261
Location: Lake Charles, USA / Rio, Brazil
@ Pikkey:

Could you please list the files on your card as I mentioned above?


Top
 Profile  
 
 Post subject: Re: *** ERROR *** No Filesystem Found
PostPosted: Fri Dec 05, 2008 4:15 pm 
Offline

Joined: Tue Dec 02, 2008 12:57 pm
Posts: 26
Location: Italy
Darrin wrote:
@ Pikkey:

Could you please list the files on your card as I mentioned above?


the core who work here is the NTSC one founded into NEWBOOT2.01.zip.
I just added the kickstart file (512K size) and I've created a SELECT.TXT file to distinguish the several folders I've created for tests, so in the MENU i can know which core I'm launching...

Ciao!

_________________
Amiga labels at: sites.google.com/site/retrolabels


Top
 Profile  
 
 Post subject: Re: *** ERROR *** No Filesystem Found
PostPosted: Fri Dec 05, 2008 4:38 pm 
Offline

Joined: Mon Dec 01, 2008 1:02 am
Posts: 109
Jens wrote me back last night.

"We're investigating this - some people were successful removing the DIMM, and we corrected a fault in the CF routines of Minimig. Only available for PAL Minimig at the moment. However, I found another error in Newboot that might confuse the memory on the extender."

"We have isolated a total of three causes that we will fix in the coming days. Luckily, it's all cores, so you will just download the updates and fix your hardware with that :-)"

It sounds like we're waiting for another Newboot at this point. Jens attached another Extender.rbf (1.11 PAL) file to me, but I actually found it also on the Forum-64 website (German Forum).

I'll attach it here also, as it seems to have helped some people. But that hasn't done the trick yet for me. Here you can see my current screenshot. The only difference is that the box w/ the error went away. Also, if you look closely, there seems to be some lines in the display. (Memory Issue?)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Translated by Xaphos © 2007, 2008, 2009 phpBB.fr